Kia Carnival Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
So unfortunately, it seems that some of us are having issues with acceleration and CEL's in cold weather. This morning was my first with the temps being around -2 degrees. I remote started the van and let it sit for about 15 minutes. When I came out to leave, I noticed the orange CEL was illuminated, and the van was acting like it was in "limp" mode. It wouldn't move under its own power in forward or reverse until I turned it off and back on again. It drove just fine after that, but the light is still on. I'm aware that the extreme cold does some unpleasant things, but I've never ran into the issue before with previous vehicles or my 13 f150.
 

·
Registered
2022 Kia Carnival SX
Joined
·
569 Posts
So unfortunately, it seems that some of us are having issues with acceleration and CEL's in cold weather. This morning was my first with the temps being around -2 degrees. I remote started the van and let it sit for about 15 minutes. When I came out to leave, I noticed the orange CEL was illuminated, and the van was acting like it was in "limp" mode. It wouldn't move under its own power in forward or reverse until I turned it off and back on again. It drove just fine after that, but the light is still on. I'm aware that the extreme cold does some unpleasant things, but I've never ran into the issue before with previous vehicles or my 13 f150.
You gotta report this to your local dealer and it wouldn't hurt to send a note to kia corporate as well.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
You gotta report this to your local dealer and it wouldn't hurt to send a note to kia corporate as well.
My dealership is aware of the issue, and they will be looking into this next week when I'm able to leave the vehicle with them.
Can't help with your problem but my question is how did you start your car up for 15 minutes? No matter what it shuts off after 10
[/QUOTE
I really never timed it, just figured it was a close approximation.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
I was going to say if you know how to change the setting please let me know. I absolutely hate that it's only 10 minutes. It's not enough time
Oh yeah I wish there was a way. It's barely enough time to get the windshield somewhat clear. All new vehicles are like that I'm pretty sure.
 

·
Registered
Joined
·
30 Posts
Oh yeah I wish there was a way. It's barely enough time to get the windshield somewhat clear. All new vehicles are like that I'm pretty sure.
Yeah this is one of the most annoying things about the car what I do is start the car at 618am and then my schedule start is at 630am. So the car shuts off for about a minute and then starts back up
 

·
Registered
Joined
·
10 Posts
I had the same issue today and was towed to dealer. If you have the Kia Access app, it should provide the diagnostic code if the engine light is on. There is also another forum “P2118 Engine Code” that other owners have shared. Sounds like a cold weather issue all around. I will post my updates on the P2118 Engine Code forum since that is the code I have. Would be curious if all the no acceleration issues when the weather is cold is the same problem.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
I had the same issue today and was towed to dealer. If you have the Kia Access app, it should provide the diagnostic code if the engine light is on. There is also another forum “P2118 Engine Code” that other owners have shared. Sounds like a cold weather issue all around. I will post my updates on the P2118 Engine Code forum since that is the code I have. Would be curious if all the no acceleration issues when the weather is cold is the same problem.
Let me know what they find. It's been tough getting to our dealership at home. I was supposed to have an appointment yesterday but the weather back home kept us from traveling. My wife is a traveling nurse and we're about 4 hours from our selling dealership. I will say It was only 4 degrees this morning and there was no issue. It's still extremely irritating seeing people having issues related to the cold.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Well I guess I should have held my tongue. I started the car this morning and same results, surging idle, and a limp mode like characteristic. Took two attempts of turning the car off and on again for it to move under its own power. It's currently 10 degrees where I'm at. I'll let you all know my findings.
 

·
Registered
Joined
·
10 Posts
I had the same issue today and was towed to dealer. If you have the Kia Access app, it should provide the diagnostic code if the engine light is on. There is also another forum “P2118 Engine Code” that other owners have shared. Sounds like a cold weather issue all around. I will post my updates on the P2118 Engine Code forum since that is the code I have. Would be curious if all the no acceleration issues when the weather is cold is the same prob
Follow up to dealer visit. When speaking with dealer service, they mentioned that they did an update so the van doesn’t go into limp mode (not mentioned on receipt) if the code resurfaces. Appears Kia is working on software update to fix this issue. Hopefully it comes soon.

Font Material property Paper Number Parallel
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
Unfortunately I wasn't able to get the car into a dealership today, but I did take it to a local shop. They read the code and sure enough it's the P2118. It's going in to the dealership on the first so we'll see what they come up with. The mechanic that ran the diagnostic believes there is moisture getting in behind the throttle body and into the intake thats freezing causing these issues.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #13 ·
This is exactly what my dealership found today. They opened at tech line on mine, and another carnival for the same problem today. Advised to do the same, let car warm up and so on. They were advised that this will be a recall, or some type of customer service bulletin and once Kia finds a fix, they will advise owners. Kia is apparently working diligently on a fix due to the number of carnivals swamping dealerships in the north, especially Canada. My service advisor said some dealerships up there have 15 or more waiting on the same issue. My dealership understands that this is frustrating.
 

·
Registered
Joined
·
1 Posts
I just ordered an SXP and am a bit worried to see all these issues being reported… they don’t function in the cold, batteries are dying/dead, sliding doors opening while driving. Any of you have more recent builds that are still experiencing these problems? I feel like I am seeing more bad than good but perhaps that is just the old reporting bias of problems over good things.
 

·
Registered
Joined
·
10 Posts
I just ordered an SXP and am a bit worried to see all these issues being reported… they don’t function in the cold, batteries are dying/dead, sliding doors opening while driving. Any of you have more recent builds that are still experiencing these problems? I feel like I am seeing more bad than good but perhaps that is just the old reporting bias of problems over good things.
I never had the door or battery issue. Issues happen in all vehicles, especially a redesign year. Hopefully most of the kinks will figured out before your delivery. I purchased at the end of April 2021…other than the engine light going on, no other issues. Just turned 11k miles this week.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #16 ·
I just ordered an SXP and am a bit worried to see all these issues being reported… they don’t function in the cold, batteries are dying/dead, sliding doors opening while driving. Any of you have more recent builds that are still experiencing these problems? I feel like I am seeing more bad than good but perhaps that is just the old reporting bias of problems over good things.
I wouldn't stress too much about what you are reading. It's a new model, so issues are almost always expected. I've never experienced the battery and door issues. My issue is more annoying than anything.
 

·
Registered
Joined
·
5 Posts
I’ve been scouring this forum to see if there is anyone out there that has a the dead battery issue completely fixed. We already had the throttle actuator control motor fixed. My salesman told me they’ve got someone else that has the doors flying open too. What a disaster…
 
1 - 17 of 17 Posts
Top