Kia Carnival Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
I have the 2022 KIA Carnival EX, the current mileage is 900 km, it's in the first week. Unfortunately, I am experiencing some issues with this car, and the major one is the Engine Sign. I booked an appointment at the nearest dealership. They fixed the problem for three days, and the same issue returned back (the engine light is ON ).

Has anyone experienced the same issue? If yes, could you please advise what to do rather than taking the car to the service center?

Other issues:
  1. The wireless charger is disconnecting frequently.
  2. The Phone projection is sometimes disconnecting.
Regards
MJ
 

·
Registered
Joined
·
5 Posts
Following as this happened to me today. Upon driving to work this morning all the warnings and lights known to man started flashing on my cluster. I had 11 different warnings ranging from forward collision to blind spot to liftgate issues. My speedometer and rpm stopped working, KMS weren't being counted and it was beeping like crazy. Car seemed to drive perfectly fine though. Got to work and all that is on now is the check engine light. Only 4500kms on vehicle. very disappointing.
 

·
Registered
Joined
·
9 Posts
I have the 2022 KIA Carnival EX, the current mileage is 900 km, it's in the first week. Unfortunately, I am experiencing some issues with this car, and the major one is the Engine Sign. I booked an appointment at the nearest dealership. They fixed the problem for three days, and the same issue returned back (the engine light is ON ).

Has anyone experienced the same issue? If yes, could you please advise what to do rather than taking the car to the service center?

Other issues:
  1. The wireless charger is disconnecting frequently.
  2. The Phone projection is sometimes disconnecting.
Regards
MJ
Do you know at what was the trouble code for the engine light?
 

·
Registered
Joined
·
3 Posts
I have the 2022 KIA Carnival EX, the current mileage is 900 km, it's in the first week. Unfortunately, I am experiencing some issues with this car, and the major one is the Engine Sign. I booked an appointment at the nearest dealership. They fixed the problem for three days, and the same issue returned back (the engine light is ON ).

Has anyone experienced the same issue? If yes, could you please advise what to do rather than taking the car to the service center?

Other issues:
  1. The wireless charger is disconnecting frequently.
  2. The Phone projection is sometimes disconnecting.
Regards
MJ
Today
I have the 2022 KIA Carnival EX, the current mileage is 900 km, it's in the first week. Unfortunately, I am experiencing some issues with this car, and the major one is the Engine Sign. I booked an appointment at the nearest dealership. They fixed the problem for three days, and the same issue returned back (the engine light is ON ).

Has anyone experienced the same issue? If yes, could you please advise what to do rather than taking the car to the service center?

Other issues:
  1. The wireless charger is disconnecting frequently.
  2. The Phone projection is sometimes disconnecting.
Regards
MJ
Today when i was turning left, all of a sudden my screen says that "engine control system is detected please call dealer as possible " and notice my engine light is on. I lost power and can drive only up to 15km per hour...it's unsafe since i am crossing left on intersection. It's 2022 kia carnival Sx with 6000 km on it. I called kia dealer and told me that they can book it on February 22. Im very disappointed... and I talked to a manager and book me earlier on January 13.
 

·
Registered
Joined
·
3 Posts
I have what seems to be very similar issue with my SX as well. Was it cold when it happened to yours? Mine and several others have this issue when it's colder than -22 celcius. It has something to do with the throttle body(probably a sensor). KIA Tech is currently investigating this as there was a fair amount in Quebec province as well yesterday.(It was cold outside)
 

·
Registered
Joined
·
3 Posts
I have what seems to be very similar issue with my SX as well. Was it cold when it happened to yours? Mine and several others have this issue when it's colder than -22 celcius. It has something to do with the throttle body(probably a sensor). KIA Tech is currently investigating this as there was a fair amount in Quebec province as well yesterday.(It was cold outside)
Yes it was cold but my engine is already pre warmed before I drive. The dealer just take a look at it on throttle but didn't see anything wrong so mechanic just reset and drive test it and found nothing suspicious.
 
1 - 8 of 8 Posts
Top