Kia Carnival Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
We got an LSX Carnival and the illumination is stuck on lowest setting, so it’s hard to see the dash information during sunny days. Any thoughts on how to fix it? I can push the button to raise the brightness, the brightness menu comes up, but doesn’t change when I press the +. It’s stuck at 10%.
thoughts on how to fix it?
Thank you!
 

·
Registered
‘23 Carnival SX
Joined
·
2 Posts
Hoping to get answers for a similar
Hello,
We got an LSX Carnival and the illumination is stuck on lowest setting, so it’s hard to see the dash information during sunny days. Any thoughts on how to fix it? I can push the button to raise the brightness, the brightness menu comes up, but doesn’t change when I press the +. It’s stuck at 10%.
thoughts on how to fix it?
Thank you!
Hoping to get answers for a similar question. OP, I think (I may be wrong, need to double check) when you go to car settings and change brightness, you’re changing the brightness for the current ambient light senses by the front dash sensor. My issue is, there is no programmable delay for the sensor. So every time I drive in the shadow of a tree or bridge, the dash immediately dims and then brightens. This makes no sense, my ‘16 forester and ‘14 explorer all have dim delay settings to not have this sporadic change in brightness.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hoping to get answers for a similar


Hoping to get answers for a similar question. OP, I think (I may be wrong, need to double check) when you go to car settings and change brightness, you’re changing the brightness for the current ambient light senses by the front dash sensor. My issue is, there is no programmable delay for the sensor. So every time I drive in the shadow of a tree or bridge, the dash immediately dims and then brightens. This makes no sense, my ‘16 forester and ‘14 explorer all have dim delay settings to not have this sporadic change in brightness.
I disconnected the battery for 15 mins and now it works!
under settings on the cluster, there’s a delayed light choice, which should help with the issue of lights turning immediately on when going under bridges and short tunnels.
 

·
Registered
‘23 Carnival SX
Joined
·
2 Posts
But that setting was not there until after you disconnected the battery? I’ll try disconnecting the battery, but currently there is no such setting under the illumination category in vehicle settings.
 

·
Registered
2022 Kia Carnival SX
Joined
·
643 Posts
But that setting was not there until after you disconnected the battery? I’ll try disconnecting the battery, but currently there is no such setting under the illumination category in vehicle settings.
You have a different trim than the OP, so your menu options may look different. I too don't have a delay option in my settings.
 
1 - 5 of 5 Posts
Top