Kia Carnival Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
We just had our 8 month old Carnival in for an oil change and to check the AC.
They had to fill the Freon but said no leaks (which seems very odd for an 8 month old car that we’ve used half the time without the AC).

Anyway, I just picked it up (after hours) and as soon as I turned it on it started bucking and shaking. (If they were opened I would have told them immediately). As I started to drive (local roads, low speeds) it continued to vibrate to the point that I was concerned, and was worse again when I idled.

Has anyone else experienced this? Or know what they could have done to cause this?
 

·
Registered
Joined
·
1 Posts
We just had our 8 month old Carnival in for an oil change and to check the AC.
They had to fill the Freon but said no leaks (which seems very odd for an 8 month old car that we’ve used half the time without the AC).

Anyway, I just picked it up (after hours) and as soon as I turned it on it started bucking and shaking. (If they were opened I would have told them immediately). As I started to drive (local roads, low speeds) it continued to vibrate to the point that I was concerned, and was worse again when I idled.

Has anyone else experienced this? Or know what they could have done to cause this?
AC system is a closed loop system and should not have to be serviced unless there is a leak. At 8 months there should be no issues with your AC unless the compressor is going bad already. Was the AC on when you started the vehicle?Definitely take it back to dealer as it is under warranty. I would have it done when they can be present when you pick it up. Good luck.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
So actually the AC was on when I started the car. I turned it off after a few seconds when I realized.
later that night I had the hood open while the car was running to take a look. I could definitely hear shaking but couldn’t see anything obvious. Then after couple minutes the engine went to a pure and it’s been fine since 🤷🏻‍♂️
 
1 - 3 of 3 Posts
Top