Kia Carnival Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone, Steven from Vancouver, Canada.
I have a Carnival SX and noticed that when my passenger side sliding door is opened it won't stay securely open. I first noticed this when I was parked on a downhill slope and the door kept closing when I was trying to take my son out of the car. When parked on a flat surface I can physically pull the door closed from the back of the door. The driver's side sliding door has no issue and won't close unless you activate it by the door handle, fob or interior door button. I called my dealership and they said it was related to the sliding door recall but I never encounter an issue that the door was not locked when we close the door. I think some owners under the recall have noticed that an alarm will go off to tell them the door is not locked.
Have any other owners noticed this problem with their sliding door, especially any owners that are part of the recall? My dealership service department said my problem was the first he encountered. The arrival date of the part is unknown.
Thank you and happy holidays everyone, Steven
 

·
Registered
Joined
·
9 Posts
Sounds like the locking mechanism isn't working properly. It should latch in the open position. A pull on the handle releases it.
 

·
Registered
Joined
·
9 Posts
Seems there's a recall that may be connected. If the locking mechanism isn't keeping the door closed, it may be the same mechanism that's not keeping it latched in the open position:
 

·
Registered
Joined
·
7 Posts
I experienced the opposite of the OP. Our Carnival was parked on an uphill slope and the sliding door on the passenger side wouldnt close properly. It seems like it closed fully but the cluster display was telling us it wasn't. Only when we parked on a level surface were we able to get rid of the notification/properly close the sliding door. Our Carnival is also part of the sliding door recall. Still waiting for dealer to receive the part.
 

·
Registered
Joined
·
6 Posts
For anyone having this problem I just wanted to report that we just got it fixed. It took a couple weeks for the dealer service center to get the part but once they did it was a quick fix.
 
1 - 9 of 9 Posts
Top