Kia Carnival Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Has anyone had this issue when pushing the gas it feels jerky… do you have to use the top tier fuel? This didn’t start until 900 miles(1000 now on van) it’s started at like 40 mph but now it’s almost anytime you accelerate . It’s not bad but it’s Noticeable ..
 

·
Registered
Joined
·
2 Posts
Has anyone had this issue when pushing the gas it feels jerky… do you have to use the top tier fuel? This didn’t start until 900 miles(1000 now on van) it’s started at like 40 mph but now it’s almost anytime you accelerate . It’s not bad but it’s Noticeable ..
I have not experienced this exact symptom as you describe. However, we have noticed that when driving in SMART mode, which operates in ECO mode under light (easy) driving, we have experienced some light shuttering feel when at about 40-45. It's not what I would call very noticeable-- I'd liken it to driving on an irregular surface road. Anyhow, yes I have noticed this and sounds similar to what you're experiencing. Our 'Carni-van' has about 3500 miles and is a SX-P. I was considering mentioning it too on this forum. Also, I wondered if it actually has to do with ECO mode and is actually performing properly. I'm not sure if the vehicle has this feature, but it may be part of the fuel savings programming that may (in essence) shut off fuel to some engine cylinders during low power demand for economy. I think Honda may have had this feature on the Odyssey. It can produce a slight shuttering feel. Again, I'm not sure if this is how the KIA works. Also, we've used predominantly 92/93 gas, which may be overkill. There is some conflicting info about this. Our dealer's service manager told us that 87 was fine, but he said higher octane would provide better mpg and lower emission (I'm not worried about the emissions, frankly.) He also did not seem to be aware of the owner's manual suggesting higher octane gas vs. gas additives every 8K. It will be interesting to get feedback from other owners on this.
 

·
Registered
Joined
·
18 Posts
Mine is now at 1700 miles and I have not experienced the jerky acceleration. My first 1000 miles was under comfort mode and I switched to smart mode later on. I feel Carnival’s NA engine is much smoother than my 2020 Range Rover which is super jerky at low speed.
 

·
Registered
2022 Kia Carnival SX
Joined
·
427 Posts
500 miles. Normal driving mode, no jerkiness at all, but I also baby it until the new car smell wears off ☺
 

·
Registered
Joined
·
7 Posts
Mine is now at 1700 miles and I have not experienced the jerky acceleration. My first 1000 miles was under comfort mode and I switched to smart mode later on. I feel Carnival’s NA engine is much smoother than my 2020 Range Rover which is super jerky at low speed.
I'm at 600 miles and have not noticed this. I have noticed that the driving mode seems to reset to Normal each time I start the car. While driving, if I hit the Drive Mode, it always goes to ECO, no matter what mode I left it in when I last shut off the car. So I think it resets to Normal after each start. Possibly this configures as part of my Profile. I don't know if I even have it set there... I'm still learning this car.
 

·
Registered
Joined
·
18 Posts
My drive mode always stay in smart. I don’t have profile set up maybe that’s why

I'm at 600 miles and have not noticed this. I have noticed that the driving mode seems to reset to Normal each time I start the car. While driving, if I hit the Drive Mode, it always goes to ECO, no matter what mode I left it in when I last shut off the car. So I think it resets to Normal after each start. Possibly this configures as part of my Profile. I don't know if I even have it set there... I'm still learning this car.
 

·
Registered
Joined
·
113 Posts
I'm at 600 miles and have not noticed this. I have noticed that the driving mode seems to reset to Normal each time I start the car. While driving, if I hit the Drive Mode, it always goes to ECO, no matter what mode I left it in when I last shut off the car. So I think it resets to Normal after each start. Possibly this configures as part of my Profile. I don't know if I even have it set there... I'm still learning this car.
Mine stays in smart even when leaving or turning off the car.
 

·
Registered
Joined
·
2 Posts
Has anyone had this issue when pushing the gas it feels jerky… do you have to use the top tier fuel? This didn’t start until 900 miles(1000 now on van) it’s started at like 40 mph but now it’s almost anytime you accelerate . It’s not bad but it’s Noticeable ..
Same issue here. At first I wasn't sure if it was that the suspension that was very sensible, but the other day I was going almost stopped and the engine really hesitated. It's like for a couple of seconds, the engine is misfirering. Don't know what to think about it... I've been using 87 regular gas. Maybe I should try one of those additives. Pretty sure Kia don't have a OEM brand, they don't even have a Kia specific oil. Does anybody know what they recommend for an additive?
 

·
Registered
Joined
·
113 Posts
Same issue here. At first I wasn't sure if it was that the suspension that was very sensible, but the other day I was going almost stopped and the engine really hesitated. It's like for a couple of seconds, the engine is misfirering. Don't know what to think about it... I've been using 87 regular gas. Maybe I should try one of those additives. Pretty sure Kia don't have a OEM brand, they don't even have a Kia specific oil. Does anybody know what they recommend for an additive?
I don't know for sure but I know they recommend Top tier gas.
 

·
Registered
Joined
·
2 Posts
I don't know for sure but I know they recommend Top tier gas.
Not sure about that... on page says to use 87 gas, another page says 91. Called my local dealer and they told me to use 87, but don't know how well they know Carnivals yet... But maybe that's the problem Maybe I should try 91 gas and see how it goes.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #11 ·
Same issue here. At first I wasn't sure if it was that the suspension that was very sensible, but the other day I was going almost stopped and the engine really hesitated. It's like for a couple of seconds, the engine is misfirering. Don't know what to think about it... I've been using 87 regular gas. Maybe I should try one of those additives. Pretty sure Kia don't have a OEM brand, they don't even have a Kia specific oil. Does anybody know what they recommend for an additive?
My carnival is doing better since we started using the top tier gas… the manual saids use it the dealer said it doesn’t matter. I use the top tier every other time I get gas and it seems like it solved the problem . My van does not like Walmart gas , I notice every time I got gas there that’s when itreally acted up.hope this helps.
 

·
Registered
Joined
·
113 Posts
Not sure about that... on page says to use 87 gas, another page says 91. Called my local dealer and they told me to use 87, but don't know how well they know Carnivals yet... But maybe that's the problem Maybe I should try 91 gas and see how it goes.
I use 87. The manual says it's recommended to use top tier gas so gas stations like ExxonMobil for example because they have added additives in their gas.
 

·
Registered
2022 Kia Carnival SX
Joined
·
427 Posts
Not sure about that... on page says to use 87 gas, another page says 91. Called my local dealer and they told me to use 87, but don't know how well they know Carnivals yet... But maybe that's the problem Maybe I should try 91 gas and see how it goes.
To be clear, "Top Tier" is a designation for gas quality, not octane levels. So, you can get "Top Tier" gas with only an 87 Octane rating. Essentially, stay away from "cheap" gas stations that may not have the cleanest gas supplies.

 

·
Registered
Joined
·
1 Posts
Has anyone had this issue when pushing the gas it feels jerky… do you have to use the top tier fuel? This didn’t start until 900 miles(1000 now on van) it’s started at like 40 mph but now it’s almost anytime you accelerate . It’s not bad but it’s Noticeable ..
Ye sim having this same issue it’s happened like 4-5 times now. At low speed or barely accelerating. Like the fuel pump isn’t pumping or something
 

·
Registered
Joined
·
15 Posts
Ye sim having this same issue it’s happened like 4-5 times now. At low speed or barely accelerating. Like the fuel pump isn’t pumping or something
Make it three. Happens around 40-45; feels almost like the engine cuts out for a split second. Doesn't seem to be triggering any codes, and I can't reproduce it often enough to take it into the dealer.
 

·
Registered
Joined
·
137 Posts
Make it three. Happens around 40-45; feels almost like the engine cuts out for a split second. Doesn't seem to be triggering any codes, and I can't reproduce it often enough to take it into the dealer.
Are you all experiencing it with smart cruise control on, off or in both scenarios? The only time I experienced something like that was with it on and it stopped after I cancelled it.
Am wondering if the issue is with that system causing it...
 

·
Registered
Joined
·
15 Posts
We’ve had our Carnival about a month now. It’s happened 4-5 times, and I don’t think any of them were while using cruise.
 
1 - 20 of 23 Posts
Top